import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w{2}(?:\\s*\\w+)*";
final String string = "{ ? <> <> ; <> ? ; <> ? . ? <> ? . ? <> ? . ? <> ? }\n"
+ "{ <> <> ? . <> <> ? }\n"
+ "{ <> <> <> }\n"
+ "{ OPTIONAL { <> <> ? } FILTER ( ! bound(?) ) }\n"
+ "{ FILTER not exists ( ! bound(?) ) }\n"
+ "{ <> <> ? . ? <> ? }\n"
+ "{ ? <> <> ; a <> }\n"
+ "{ <> <> ?@en }\n"
+ "{ <> <> <> }\n"
+ "{ <> <> ? . <> <> ? FILTER ( ? > ? ) }\n"
+ "{ <> <> ? . ? <> ? FILTER regex(? ?) }\n"
+ "{ <> <> ? FILTER ( ! bound(?) ) }\n"
+ "{ ? <> ? ; <> ? . ? <> ? }\n"
+ "{ ? <> ? ; <> ? . ?2 <> ? ; <> ? }\n"
+ "{ ? <> <> ; <> ? . ? <> ? }\n"
+ "{ <> <> ? . <> <> ? FILTER ( ? = ? ) }\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}