$re = '/\b\w*(\w)\1{2}\w*/';
$str = 'II loooovve this video. It\'s awesooooommeee.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);