import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([0-9A-Fa-f]{1,4}:){7})([0-9A-Fa-f]{1,4})$|(([0-9A-Fa-f]{1,4}:){1,6}:)(([0-9A-Fa-f]{1,4}:){0,4})([0-9A-Fa-f]{1,4})$";
final String string = "fe80::21d8:f50:c295:c4be\n"
+ "2001:cdba:0000:0000:0000:0000:3257:9652\n"
+ "2001:cdba:0:0:0:0:3257:9652\n"
+ "2001:cdba::3257:9652\n"
+ "2001:cdba::1222\n"
+ "1200:0000:AB00:1234:0000:2552:7777:1313:afed\n"
+ "21DA:D3:0:2F3B:2AA:FF:FE28:9C5A\n"
+ "2001:cdba::1:2:3:3257:9652\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}