$re = '/^(?=.*\d)[a-zA-Z\d]+$/';
$str = 'a1b2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);