$re = '/^(?<Text>(?:(?!:\d+).)+(?=$|\s+:(?<Number>\d+)$))/m';
$str = 'foo :6
foo 8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);