#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^Ответ: ((.|\n)+?)\n([0-9\n])"
Local $sString = "Тема 1: Стихийные бедствия." & @CRLF & _
"Автор: Булат Фаттахов" & @CRLF & _
"10. Таким женским именем звали ураган, сильно повредивший Новый Орлеан." & @CRLF & _
"Ответ: Катрина." & @CRLF & _
"20. "Дождь лил четыре года, одиннадцать месяцев и два дня" именно там." & @CRLF & _
"Ответ: в Макондо." & @CRLF & _
"30. В 1883 году было извержение вулкана именно на этом острове." & @CRLF & _
"Ответ: Кракатау (Остров назывался так же как и вулкан)." & @CRLF & _
"40. Армянские города Гюмри и Ванадзор, сильно пострадавшие во время землетрясения 1988 года, в советское время носили такие названия." & @CRLF & _
"Ответ: Ленинакан и Кировокан." & @CRLF & _
"50. Крупнейшее за всю историю человечества это стихийное бедствие произошло в 1875 году в США, а не в Египте двумя тысячами годами ранее." & @CRLF & _
"Ответ: Нашествие саранчи." & @CRLF & _
"" & @CRLF & _
"Тема 2: Города России." & @CRLF & _
"Автор: Булат Фаттахов" & @CRLF & _
"10. Это крупнейший город России после Москвы." & @CRLF & _
"Ответ: Санкт-Петербург." & @CRLF & _
"20. Москва крупнейший город России, а Тольятти тоже крупнейший город в России среди таких." & @CRLF & _
"Ответ: Не являющийся столицей региона." & @CRLF & _
"30. Это - крупнейший город самого большого острова России." & @CRLF & _
"Ответ: Южно-Сахалинск." & @CRLF & _
"40. Именно в этом городе происходит действие сериала "Счастливы вместе"." & @CRLF & _
"Ответ: Екатеринбург." & @CRLF & _
"50. А именно этот город является самым западным городом России." & @CRLF & _
"Ответ: Балтийск."
Local $sSubst = "Ответ: <details>\1</details>\n$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)