$re = '/translatedText": (.*?),/';
$str = 'translateText({
"data":{
"translations":[
{
"translatedText": "Ola Mundo",
"detectedSourceLanguage": "en"
}
]
}
}
);';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);