const regex = /^(.+?)\s(\/[^?]*)(\?([^&]+=[^&\s]+&?)+)?\sHTTP\/\d\.\d$/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+?)\\s(\\\/[^?]*)(\\?([^&]+=[^&\\s]+&?)+)?\\sHTTP\\\/\\d\\.\\d$', 'mig')
const str = `GET /index.html?x=1&y=2 HTTP/1.1
GET /index.html HTTP/1.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}