$re = '/^(0[7-8])/m';
$str = '08863
07963
08559';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);