$re = '/\b((ht|f)tp(s)?:\/\/|www\.)+[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9]{2,}((\/)?([-a-zA-Z0-9@:%_\+.~#?&\/=]*)?)\b/m';
$str = 'https://www.dfir-alliance.net/
https://www.ibm.com/developerworks/community/groups/service/html/communityview?communityUuid=2245aa39-fa5c-4475-b891-14c205f7333c
https://www.ibm.com/search?lang=en&cc=us&q=thread%20dump%20analyzer%20download,whatever
https://www.ibm.com/support/pages/ibm-thread-and-monitor-dump-analyzer-java-tmda
https://www.ibm.com/support/pages/ibm-thread-and-monitor-dump-analyzer-java-tmda?mhsrc=ibmsearch_a&mhq=thread%20dump%20analyzer%20download|dfd
ftp://whatever.de
https://espn.com
https://www.espn.com
http://www.coderjournal.com
http://coderjournal.net
http://coderjournal.org
e Cookies,WEBHIST,...b,0,https://softpedia.com/another%20string
https://mywebsite.com:9100/index.asp
http://www.example.com/questions/3456/my-document
https://mywebsite.com:9100/
www.espn.com/
www.espn.co.uk/
www.longTLD-testing.careers/username=119684548977
espn.com
microsoft.com&form=B00032&ocid=SettingsHAQ-BingIA&mkt=en-US
http://microsoft.com/&form=B00032&ocid=SettingsHAQ-BingIA&mkt=en-US
https://this-shouldn\'t.match@example.com
my-burner-email@protonmail.com
another_burner.co.uk@tutanota.com
System.evtx
TIFImage.Document_.tiff:
Training.pdf
UsrClass.dat
com.ibm.cloud.console.analytics.anonymousId)
com.jabra.directonline:
com.squirrel.Teams.Teams:
com.squirrel.slack.slack:
docxfile_.docx/vba
htmlfile_.html:
SourceForge.net)
Office\\root\\Office16\\EXCEL.EXE:
Office\\root\\Office16\\OUTLOOK.EXE:
Office\\root\\Office16\\POWERPNT.EXE:
Office\\root\\Office16\\WINWORD.EXE:
C:\\Users\\User\\AppData\\Local\\Temp\\is-I16AS.tmp\\SIS119_Setup.tmp
..\\..\\..\\..\\..\\..\\..\\Downloads\\malware.zip
ma.b
zoom.us.Zoom
2.0.13
2.0.13.0
0321.zip
0321.zip.lnk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);