$re = '~^/(?:api|web)/(\w+)/v1/method~m';
$str = '/api/application/v1/method
/web/application/v1/method';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);