using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([\w\-\.]*)@([\w\.]*[.][\w]{2,3}))$";
string input = @"me@ruben.co.uk";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}