$re = '/.*?0*(\d+).*/m';
$str = '--- 01 ---
--- 03 ---
--- 25 ---
--- 150 ---
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);