$re = '~^(\+)|\D~m';
$str = '+foo56565+ksjk';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;