$re = '/(?<!\d)\d{5}(?!\d)/';
$str = 'a12345 12345 a12345a 12345a 123456 1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);