re = /\S*\s?\S*\s?magna\s?\S*\s?\S*/m
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end