$re = '/(0[1-9]|1\d{1}|2\d{1}|3[0-1])(\/|\-|\.)(0[1-9]|[1-9]|1[0-2])\2\d{4}/m';
$str = '01/02/2010
31-03-2009
28.04.2009
29.05.2019
28.06.2019
15.07-2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);