re = /.*RegExp\(([^)]*)\).*/mi
str = 'RegExp("myregex")
RegExp("something"); myfunction("something")
RegExp("my(regex)")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end