re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[ -\/:-@\[-`{-~]).{6,64}$/
str = 'aS1*rt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end