package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div.*?>\d+<\/div>`)
var str = `<div>ABC</div><div>123</div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}