package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)/^\s*([a-z]+)`)
var str = `GigabitEthernet3/1/4.121`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}