re = /^(([^<>()[\]\.,;:\s@\"]+(\.[^<>()[\]\.,;:\s@\"]+)*)|(\".+\"))@(([^<>()[\]\.,;:\s@\"]+\.)+[^<>()[\]\.,;:\s@\"]{2,})$/i
str = 'praxis@dr-düringer.hamburg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end