$re = '/\b(?=\w*(\w)\1)\w+\b/';
$str = 'here areee some testtting words';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);