import re
regex = re.compile(r"^(([:][a-z]+)?\s*([\+|\-]?)\s*(nop|mov|jmp|slp|slx|add|sub|mul|not|dgt|dst|teq|tgt|tlt|tcp)\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*(acc|dat|p[\d+]|x[\d+]|[\d+])\s*|[#].*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = (":label +mov acc dat This is a label and instruction with a conditional execution\n"
"+mov acc dat This is a \n"
"mov acc 1 awdasda \n"
"+mov acc dat")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")