re = /(?<=<START>).+\n.+/m
str = '<START> some text is here.
more text
unrelated text
<START> even more text.
text text
<STOP>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end