using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/blog\/+^(?!.*tag).*$";
string input = @"https://www.lightspeedhq.nl/blog/tag";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}