#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(MON|MA|MES|TON|TA|TES|SON|SA|SES|LE|LA|LES|UN|UNE|DES|CECI|CETTE|CES|CELA)\b"
Local $sString = "Ceci est un fichier texte, qui permettra entre autre le test du Tokenizing en Java. Il aura pour but de différencier 3 types de tokens: " & @CRLF & _
"- Les mots," & @CRLF & _
"- Les phrases," & @CRLF & _
"- Les questions." & @CRLF & _
"" & @CRLF & _
"Chacun d'entre eux sont particuliers, entre autre, le mot est similaire à l'appélation classique. Les phrases sont, par définition, un ensemble de mots" & @CRLF & _
"délimités entre deux points. Quant aux questions, elles sont délimitées par un point d'intérrogation et par une expression définie selon la langue, un mot intérrogatif." & @CRLF & _
"" & @CRLF & _
"Comment procéder à tout ça?" & @CRLF & _
"" & @CRLF & _
"Les étapes se divisent de plusieurs manières." & @CRLF & _
"" & @CRLF & _
"On va d'abord prendre en entrée un texte classique pour tester la tokenization en mots. Une fois validée, nous passeront au tests sur fichier txt," & @CRLF & _
"puis enfin, nous tenterons de différencier les phrases." & @CRLF & _
"" & @CRLF & _
"Faut-il pour autant limiter les intérrogations aux simples mots classiques de la langue française?" & @CRLF & _
"" & @CRLF & _
"Cette phrase juste avant est, en l'occurence, une intérrogation, ne commançant par aucun mot intérrogatif." & @CRLF & _
"" & @CRLF & _
"Enervant, n'est-ce-pas? Parce que je recommence, j'aime m'ajouter du challenge!" & @CRLF & _
"" & @CRLF & _
"Oups, j'ai ajouté une phrase exclamative! Et encore une! Bon, ok, j'arrête... Et de la suspension maintenant." & @CRLF & _
"" & @CRLF & _
"Bon, je pense que je vais m'arrêter là pour le fichier, ça devient trop là." & @CRLF & _
"" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam," & @CRLF & _
"quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident," & @CRLF & _
"sunt in culpa qui officia deserunt mollit anim id est laborum." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")