$re = '/\[start\](.*?)\[stop\]
/';
$str = '[start]test1[stop] [start]test2[stop][start]test3[stop]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);