package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(a)+bc`)
var str = `aaaaaabc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}