const regex = /(<([\w\:\-]+)(.+?)<\/\2>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<([\\w\\:\\-]+)(.+?)<\\\/\\2>)', '')
const str = ` <model name="user" label="User / Device"> <field name="device_label" label="Device Label" type="text:name" /> <field name="logged_in_as_administrator" label="Logged in as Administrator" type="boolean" /> <field name="logged_in_as_consultant" label="Logged in as Consultant" type="boolean" /> <field name="logged_in_as_contractor" label="Logged in as Contractor" type="boolean" /> <field name="logged_in_as_csd" label="Logged in as CSD" type="boolean" /> <field name="logged_in_as_engineer" label="Logged in as Engineer" type="boolean" /> <field name="logged_in_as_engineer_coordinator" label="Logged in as Operations Coordinator" type="boolean" /> <field name="logged_in_as_procurement" label="Logged in as Procurement" type="boolean" /> <field name="logged_in_as_sda" label="Logged in as SDA" type="boolean" /> <field name="logged_in_as_pm" label="Logged in as Project Manager" type="boolean" /> <field name="app_version" label="App Version" type="text" /> <field name="updated_at" label="Updated At" type="text" /> <belongs-to model="journey_account" /> <belongs-to model="role" name="current_role" /> <has-many model="notification" name="notifications" /> <display>{device_label}</display> </model> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}