$re = '/(_id`|\.`id`)\s*(!?=\s*\d+|IN\s*\([\d\,\s]*\))|FOR UPDATE|`ancestry`\s*(=|LIKE)\s*\'.*\'/';
$str = 'SELECT `ca_test`.`ex_journal_events`.* FROM `ca_test`.`ex_journal_events` WHERE `ca_test`.`ex_journal_events`.`office_id` = 36 AND `ca_test`.`ex_journal_events`.`office_member_id` = 6 LIMIT 1 FOR UPDATE WHERE `ca_production`.`office_member_depts`.`office_member_id` IN (6, 7)
SELECT `ca_test`.`ex_journal_events`.* FROM `ca_test`.`ex_journal_events` WHERE `ca_test`.`ex_journal_events`.`office_member`.`id` = 6
SELECT `ca_test`.`ex_journal_events`.* FROM `ca_test`.`ex_journal_events` WHERE `ca_test`.`ex_journal_events`.`office`.`id` =
SELECT `ca_production`.`permission`.* FROM `ca_production`.`permission` WHERE `ca_production`.`permission`.`office_member_id` IN (6, 8)
SELECT `ca_production`.`permission`.* FROM `ca_production`.`permission` WHERE `ca_production`.`permission`.`office_id` IN (6, 8)
SELECT `ca_production`.`permission`.* FROM `ca_production`.`permission` WHERE `ca_production`.`permission`.`office_member_id`=6 FOR UPDATE
SELECT `ca_test`.`ex_journal_events`.* FROM `ca_test`.`ex_journal_events` WHERE `ca_test`.`ex_journal_events`.`office_member`.`user_id`=6
SELECT `ca_production`.`ex_items`.* FROM `ca_production`.`ex_items` WHERE `ca_production`.`ex_items`.`id` IN (5, 4)
SELECT `ca_production`.`ex_items`.* FROM `ca_production`.`ex_items` WHERE `ca_production`.`ex_items`.`id` = 5
`permission`.`function_id` IN (6501, 6502, 6503) (pid:72013)
(0.6ms) SELECT DISTINCT `ca_production`.`office_member`.`office_id` FROM `ca_production`.`office_member` INNER JOIN `ca_production`.`permission` ON `ca_production`.`permission`.`office_member_id` = `ca_production`.`office_member`.`id` WHERE `ca_production`.`office_member`.`deleted_at` IS NULL AND `ca_production`.`office_member`.`user_id` = 43 AND `permission`.`function_id` IN (6501, 6502, 6503) (pid:72013)
SELECT `ca_production`.`project_codes`.* FROM `ca_production`.`project_codes` WHERE (`ca_production`.`project_codes`.`ancestry` LIKE \'283653/%\' OR `ca_production`.`project_codes`.`ancestry` = \'283653\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);