const regex = /(id="mce_[^"]+")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(id="mce_[^"]+")', 'g')
const str = `<section id="defaultSection">
<div class="container">
<div class="row" id="mce_30" ><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir + </a></div></div><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir +</a></div></div><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg" data-mce-selected="1"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir +</a></div></div><div id="mceResizeHandlenw" data-mce-bogus="all" class="mce-resizehandle" unselectable="true" style="cursor: nw-resize; margin: 0px; padding: 0px; left: 838.5px; top: -4.5px;"></div><div id="mceResizeHandlene" data-mce-bogus="all" class="mce-resizehandle" unselectable="true" style="cursor: ne-resize; margin: 0px; padding: 0px; left: 1235.296875px; top: -4.5px;"></div><div id="mceResizeHandlese" data-mce-bogus="all" class="mce-resizehandle" unselectable="true" style="cursor: se-resize; margin: 0px; padding: 0px; left: 1235.296875px; top: 293.5px;"></div><div id="mceResizeHandlesw" data-mce-bogus="all" class="mce-resizehandle" unselectable="true" style="cursor: sw-resize; margin: 0px; padding: 0px; left: 838.5px; top: 293.5px;"></div></div>
</div>
</section>
<section id="section6416597692295909"><div class="container"><div class="row editable" id="mce_31" ><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir + </a></div></div><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir +</a></div></div><div class="third centerText overflowHidden"><div><img src="http://templates.weesoo.com/dummy1.jpg" class="fullWidth" data-mce-src="http://templates.weesoo.com/dummy1.jpg"></div><h3>Lorem ipsum</h3><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.</p><div><a href="#" class="btnColor1 floatRight" data-mce-href="#">En savoir +</a></div></div></div></div></section>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}