import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=(\"|')(https?:)?\\/\\/(*SKIP)(*FAIL)|href=(\"|')(.*?)\\3";
final String string = "<a href=\"//website.com/\" />\n"
+ " <a href=\"/link1\" />\n"
+ " <a href=\"https://website.com\" />\n"
+ " <a href=\"link1\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}