re = /\b\w*(\w)\1\w*/
str = 'II loooovve this video. It\'s awesooooommeee vidieo.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end