import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/(?!(admin\\b)|login\\b\\/*|home\\b\\/*|sign_up\\b\\/*)[a-zA-Z0-9_\\/]*";
final String string = "/\n"
+ "/admin\n"
+ "/login\n"
+ "/admin/xxx\n"
+ "/login/xxx\n"
+ "/home/xxx/login/xxx\n"
+ "/sign_up/xxx/login/xxx\n"
+ "/admintest/xxx\n"
+ "/loginetest/xxx\n"
+ "/hometset/xxx\n"
+ "/sign_uptest/xxx\n"
+ "/others\n"
+ "/others/xxx/login/xxx\n"
+ "/others/xxx/others/xxx/login/xxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}