const regex = /(\{\".*?:.*?\"\})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{\\".*?:.*?\\"\\})', '')
const str = `<font size='1'><table class='xdebug-error xe-notice' dir='ltr' border='1' cellspacing='0' cellpadding='1'>
<tr><th align='left' bgcolor='#f57900' colspan="5"><span style='background-color: #cc0000; color: #fce94f; font-size: x-large;'>( ! )</span> Notice: Undefined index: in C:\\wamp\\www\\form.php on line <i>464</i></th></tr>
<tr><th align='left' bgcolor='#e9b96e' colspan='5'>Call Stack</th></tr>
<tr><th align='center' bgcolor='#eeeeec'>#</th><th align='left' bgcolor='#eeeeec'>Time</th><th align='left' bgcolor='#eeeeec'>Memory</th><th align='left' bgcolor='#eeeeec'>Function</th><th align='left' bgcolor='#eeeeec'>Location</th></tr>
<tr><td bgcolor='#eeeeec' align='center'>1</td><td bgcolor='#eeeeec' align='center'>0.0008</td><td bgcolor='#eeeeec' align='right'>274560</td><td bgcolor='#eeeeec'>{main}( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>0</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>2</td><td bgcolor='#eeeeec' align='center'>0.8826</td><td bgcolor='#eeeeec' align='right'>38298888</td><td bgcolor='#eeeeec'>do_action( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>85</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>3</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300392</td><td bgcolor='#eeeeec'><a href='http://www.php.net/function.call-user-func-array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}' target='_new'>call_user_func_array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}</a>
( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>4</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300560</td><td bgcolor='#eeeeec'>Example_Post->ajax_Example_posting_form( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>5</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38301552</td><td bgcolor='#eeeeec'>Example_Post->Example_form_submitting( )</td><td title='C:\\wamp\\www\\form.php' bgcolor='#eeeeec'>..\\Example-frontend-form.php<b>:</b>116</td></tr>
</table></font>
<br />
<font size='1'><table class='xdebug-error xe-notice' dir='ltr' border='1' cellspacing='0' cellpadding='1'>
<tr><th align='left' bgcolor='#f57900' colspan="5"><span style='background-color: #cc0000; color: #fce94f; font-size: x-large;'>( ! )</span> Notice: Undefined index: name in C:\\wamp\\www\\form.php on line <i>475</i></th></tr>
<tr><th align='left' bgcolor='#e9b96e' colspan='5'>Call Stack</th></tr>
<tr><th align='center' bgcolor='#eeeeec'>#</th><th align='left' bgcolor='#eeeeec'>Time</th><th align='left' bgcolor='#eeeeec'>Memory</th><th align='left' bgcolor='#eeeeec'>Function</th><th align='left' bgcolor='#eeeeec'>Location</th></tr>
<tr><td bgcolor='#eeeeec' align='center'>1</td><td bgcolor='#eeeeec' align='center'>0.0008</td><td bgcolor='#eeeeec' align='right'>274560</td><td bgcolor='#eeeeec'>{main}( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>0</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>2</td><td bgcolor='#eeeeec' align='center'>0.8826</td><td bgcolor='#eeeeec' align='right'>38298888</td><td bgcolor='#eeeeec'>do_action( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>85</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>3</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300392</td><td bgcolor='#eeeeec'><a href='http://www.php.net/function.call-user-func-array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}' target='_new'>call_user_func_array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}</a>
( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>4</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300560</td><td bgcolor='#eeeeec'>Example_Post->ajax_Example_posting_form( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>5</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38301552</td><td bgcolor='#eeeeec'>Example_Post->Example_form_submitting( )</td><td title='C:\\wamp\\www\\form.php' bgcolor='#eeeeec'>..\\Example-frontend-form.php<b>:</b>116</td></tr>
</table></font>
{"redirect_to":"false","show_message":true,"message":"<div class=\\"notification alert-success\\"><p>Post updated successfully<\\/p><a href=\\"#\\" class=\\"close-btn\\">\\u00d7<\\/a><\\/div><br \\/>"}
<font size='1'><table class='xdebug-error xe-notice' dir='ltr' border='1' cellspacing='0' cellpadding='1'>
<tr><th align='left' bgcolor='#f57900' colspan="5"><span style='background-color: #cc0000; color: #fce94f; font-size: x-large;'>( ! )</span> Notice: Undefined index: in C:\\wamp\\www\\form.php on line <i>464</i></th></tr>
<tr><th align='left' bgcolor='#e9b96e' colspan='5'>Call Stack</th></tr>
<tr><th align='center' bgcolor='#eeeeec'>#</th><th align='left' bgcolor='#eeeeec'>Time</th><th align='left' bgcolor='#eeeeec'>Memory</th><th align='left' bgcolor='#eeeeec'>Function</th><th align='left' bgcolor='#eeeeec'>Location</th></tr>
<tr><td bgcolor='#eeeeec' align='center'>1</td><td bgcolor='#eeeeec' align='center'>0.0008</td><td bgcolor='#eeeeec' align='right'>274560</td><td bgcolor='#eeeeec'>{main}( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>0</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>2</td><td bgcolor='#eeeeec' align='center'>0.8826</td><td bgcolor='#eeeeec' align='right'>38298888</td><td bgcolor='#eeeeec'>do_action( )</td><td title='C:\\wamp\\www\\Example\\wp-admin\\admin-ajax.php' bgcolor='#eeeeec'>..\\admin-ajax.php<b>:</b>85</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>3</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300392</td><td bgcolor='#eeeeec'><a href='http://www.php.net/function.call-user-func-array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}' target='_new'>call_user_func_array:{C:\\wamp\\www\\Example\\wp-includes\\plugin.php:505}</a>
( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>4</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38300560</td><td bgcolor='#eeeeec'>Example_Post->ajax_Example_posting_form( )</td><td title='C:\\wamp\\www\\Example\\wp-includes\\plugin.php' bgcolor='#eeeeec'>..\\plugin.php<b>:</b>505</td></tr>
<tr><td bgcolor='#eeeeec' align='center'>5</td><td bgcolor='#eeeeec' align='center'>0.8827</td><td bgcolor='#eeeeec' align='right'>38301552</td><td bgcolor='#eeeeec'>Example_Post->Example_form_submitting( )</td><td title='C:\\wamp\\www\\form.php' bgcolor='#eeeeec'>..\\Example-frontend-form.php<b>:</b>116</td></tr>
</table></font>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}