using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{.*?}";
string input = @"This is the string and it contains {0} a few {1} sets of curly brackets
This is the string and it contains {0} a few {1} sets of curly brackets
This is the string and it contains {0} a few {1} sets of curly brackets
{1} s;d
adkfjdakjf{skdjksdjksjd}
jahf{lksjfdkdsjf}dkjkds
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}