package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[([^\[\]]*)\]\]`)
var str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Sed aliquet imperdiet sapien, [[xx]] vitae luctus augue convallis quis. Pellentesque felis eros, dignissim vitae [[ccvf] dignissim sed, porta a leo. Duis tincidunt, ex sit amet sollicitudin vehicula, nibh velit ultrices ipsum, at feugiat enim arcu et [[dfg]] enim. [[abc Lorem ipsum [[xyz]] dolor sit amet, consectetur adipiscing elit. Sed aliquet imperdiet sapien.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}