import re
regex = re.compile(r"Køretøjsliste for \d{7} for dato \d{2}.\d{2}.\d{4} - \d{2}.\d{2}.\d{4}.xls", flags=re.MULTILINE)
test_str = ("Køretøjsliste for 4874349 for dato 31.01.2020 - 01.05.2020.xls\n"
"Køretøjsliste for 4874351 for dato 30.02.2021 - 03.10.2021.xls\n"
"Køretøjsliste for 4874352 for dato 29.03.2022 - 09.06.2022.xls\n"
"Køretøjsliste for 4874353 for dato 28.04.2022 - 11.09.2022.xls\n"
"Køretøjsliste for 4874354 for dato 27.05.2022 - 15.12.2022.xls\n"
"Køretøjsliste for 4874355 for dato 26.06.2023 - 22.07.2023.xls\n"
"Køretøjsliste for 4874356 for dato 25.07.2022 - 27.08.2022.xls\n"
"Køretøjsliste for 4874357 for dato 24.09.2029 - 28.12.2029.xls\n"
"Køretøjsliste for 4874358 for dato 11.10.2015 - 29.10.2015.xls\n"
"Køretøjsliste for 4874359 for dato 04.11.2024 - 30.11.2025.xls\n"
"Køretøjsliste for 4874360 for dato 01.12.2028 - 31.12.2029.xls")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")