import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\/\\*.*?\\*\\/";
final String string = "/**\n"
+ " * base comment\n"
+ " * (c) SOMEBODY SOMETIME\n"
+ " * something\n"
+ " */\n\n"
+ "///<!-- ------metadata-XML------- -->\n"
+ "/// <module type=\"javascript\"> A\n"
+ "///<desc> some desc \n"
+ "/// </desc> \n"
+ "(function( a /* param A */) { // programmers comment ... enclosure\n"
+ "/*! user doc\n"
+ " this module ....\n"
+ " * reguired\n"
+ ".....\n"
+ "*/\n"
+ "var b={}; // programmers in line comment\n"
+ "// single line comments\n\n"
+ "// The cookie spec says up to 4k per cookie, so at ~50 bytes per entry\n"
+ "// that gives a maximum of around 80 items as a max value for this field\n"
+ " b.a=a;\n"
+ " var str = \" tttt //this is not comment ! tttt \"\n"
+ " var str2 = \" tttt /* this is not comment too ! \\\n"
+ ".............. */ ttt \";\n"
+ " global.b = b; \n"
+ "}(global);\n"
+ "///</module>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}