$re = '/(?<!\S)#test\b/m';
$str = 'This is just a #test that isn\'t working
#test that isn\'t working
that isn\'t working #test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;