package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*([-+]?)(\d+)(?:\s*([-+*\/])\s*([-+]?)(\d+)\s*)+$`)
var str = `5+5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}