package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\W+`)
var str = `-a _ b~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}