$re = '/^((?!=[0-9]{1,})(?!=[a-zA-Z]{1,})){6,40}$/m';
$str = 'fewf43f43f';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;