re = /(?x)
<p>.*?<\/p>/m
str = '<p>Paragraph 1</p><p>Paragraph 2</p><p>Paragraph 3</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end