use strict;
my $str = 'common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)';
my $regex = qr/(?(DEFINE)
(?<exprs> (?&expr)(\s+(?&bool)\s+((?&expr)|\(\s*(?&exprs)\s*\)))* )
(?<expr> (?&valleft)\s?(?&comp)\s?(?&valright) )
(?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )
(?<valleft> (?¬)[\w\.]+ )
(?<valright> [\w\.]+ )
(?<bool> (and|or) )
(?<not> (not\s+)?)
)
(?&exprs)/xmip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}