const regex = /^\d*\.?((25)|(50)|(5)|(75)|(0)|(00))?$
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*\\.?((25)|(50)|(5)|(75)|(0)|(00))?$
', '')
const str = `^\\d*\\.?((25)|(50)|(5)|(75)|(0)|(00))?\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}