$re = '/^(?=.*[0-9])(?=.*[a-zA-Z])[a-zA-Z0-9]{8,}$/m';
$str = 'abdcdd11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);