$re = '/^(?:[a-zA-Z0-9\/\.\?\_]|(?<!-)-)+$/m';
$str = 'quick-brown-fox
jumps--over-the--lazy-dog
jumps-over-the-lazy-dog
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);