const regex = /([\/\+][A-Za-z](-[0-9]+)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\\/\\+][A-Za-z](-[0-9]+)+)', 'g')
const str = `jkshd/asdf-asdf-34j/a-123+d-12334-234/woirjf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}